Ops One AG platform status and maintenance announcements. Times are indicated in local Swiss time. http://opsone.ch/.
All systems are operational
Scheduled Maintenance
MongoDB 4.4.10

We will update MongoDB to version 4.4.10.

Start maintenance window: 01/11/2021 23:00
Stop maintenance window: 02/11/2021 02:00

Update Discourse

We will update Discourse to version 2.7.9.

Due to the inplace upgrade feature of Discourse, no downtime will be required.

Start maintenance window: 01/11/2021 23:00
Stop maintenance window: 02/11/2021 02:00

backup: Introduction of Ops One ID Login

On Tuesday, the 16.11.2021, we will add support for our Ops One ID to the central backup webinterface This will increase security by preventing direct access to the backup webinterface without Ops One ID login.

During following maintenance window, interruptions of the service are to be expected.

Start maintenance window: 16/11/2021 09:00
Stop maintenance window: 16/11/2021 15:00

Don't hesitate to contact us if you have any questions or uncertainties.

Past Incidents

Tuesday 19th October 2021

dbadmin: Introduction of Ops One ID Login, scheduled 1 week ago

On Tuesday, the 19.10.2021, we will add support for our Ops One ID to the central database administration. This will increase security by preventing direct access to dbadmin.

During following maintenance window, interruptions of the service are to be expected.

Start maintenance window: 19/10/2021 09:00
Stop maintenance window: 19/10/2021 11:00

Don't hesitate to contact us if you have any questions or uncertainties.

Monday 4th October 2021

Update GitLab 14.2.5, scheduled 3 weeks ago

We will update GitLab to version 14.2.5.

Start maintenance window: 05/10/2021 00:00 CEST
Stop maintenance window: 05/10/2021 02:00 CEST

Cluster Maintenance, scheduled 3 weeks ago

We are performing maintenance on our Nutanix cluster. During this time, there may be higher disk i/o.

Start maintenance window: 04/10/2021 23:00
Stop maintenance window: 05/10/2021 06:00

Sunday 3rd October 2021

No incidents reported

Saturday 2nd October 2021

No incidents reported

Friday 1st October 2021

No incidents reported

Thursday 30th September 2021

Version 5 Managed Server Version 5: Client Connection Errors to Let's Encrypt Certificates

On September 30, 2021, an intermediate certificate used in Let's Encrypt certificates did expire. Even though those certificates are signed with another, valid certificate path, openssl version prior 1.1.0 will use the former, now invalid path to validate a connection. This does affect our managed server version 5 (EOL May 2020). If you encounter any problems, please consider upgrading your server to a new, supported version. If you require the implementation of a short-term workaround, please contact us to validate all possible options.

Technical Details:

  • affected Certificate: DST Root CA X3
  • affected OpenSSL version: older than 1.1.0
  • affected Debian version: 8 (Jessie) and older
  • affacted Ops One Managed Server Version: 5 and older
  • Let's Encrypt Article

Wednesday 29th September 2021

Managed Server Version 8: TYPO3 v11.4.0

We've just released TYPO3 v11.4.0 – the last sprint release of the 11.x release series before TYPO3 v11 LTS is out.

TYPO3 v11.4 ships with new features for editors, improvements for site admins and integrators as well as developers.

For details about the release, please see:

https://typo3.org/article/typo3-version-114-into-new-galaxies

reference opensource/puppet-modules#1052

Managed Server Version 7: TYPO3 v11.4.0

We've just released TYPO3 v11.4.0 – the last sprint release of the 11.x release series before TYPO3 v11 LTS is out.

TYPO3 v11.4 ships with new features for editors, improvements for site admins and integrators as well as developers.

For details about the release, please see:

https://typo3.org/article/typo3-version-114-into-new-galaxies

reference opensource/puppet-modules#1052

Tuesday 28th September 2021

No incidents reported

Monday 27th September 2021

Managed Server Version 8: Reboot, scheduled 1 month ago

To load new kernel versions, we will reboot all Managed Server during our next maintenance window.

Start maintenance window: 27/09/2021 23:00
Stop maintenance window: 28/09/2021 03:00

Managed Server Version 6: Openssl Update, scheduled 1 month ago

We will update the following packages to the latest version.

libssl-dev/oldoldstable 1.1.0l-1~deb9u4 amd64 [upgradable from: 1.1.0l-1~deb9u3]
libssl-doc/oldoldstable 1.1.0l-1~deb9u4 all [upgradable from: 1.1.0l-1~deb9u3]
libssl1.1/oldoldstable 1.1.0l-1~deb9u4 amd64 [upgradable from: 1.1.0l-1~deb9u3]
openssl/oldoldstable 1.1.0l-1~deb9u4 amd64 [upgradable from: 1.1.0l-1~deb9u3]

Start maintenance window: 27/09/2021 23:00
Stop maintenance window: 28/09/2021 01:00